Crosswords for Mac Support

Available on the Mac App Store

System Requirements

Crosswords requires Mac OS X 10.6.6 or later, and is only available via the Mac App Store.

Syncing to an iPhone, iPad or iPod requires the purchase of Crosswords for iPhone/iPad, available in the iTunes App Store.

View the Crosswords for Mac FAQ! Have questions about Crosswords for Mac? Find answers at the Crosswords for Mac Frequently Asked Questions page!

Follow us on Twitter to be notified of the latest Crosswords updates!

Having problems with Crosswords? Fill out the form below to tell us about it, or email us directly at!